Search Results for 'Cisco'

4 POSTS

  1. 2008.09.29 Cisco TFTP 다운
  2. 2008.09.29 Switch Load Balancing
  3. 2008.09.22 Cisco 3750 기본 셋팅
  4. 2008.09.22 라우터 관리를 위한 명령어

Cisco TFTP 다운

Posted 2008. 9. 29. 07:16



 

Cisco Route, Switch 에서 설정(Config) 파일을 FTP 다운받을수 있게 서버 역활을 하는 프로그램입니다.

Cisco 장비는 이 프로그램이 없다면 Config 파일을 다운 받을수가 없습니다.

'Network > Cisco' 카테고리의 다른 글

Cisco TFTP 다운  (0) 2008.09.29
Switch Load Balancing  (0) 2008.09.29
Cisco 3750 기본 셋팅  (0) 2008.09.22
라우터 관리를 위한 명령어  (0) 2008.09.22
Write your message and submit

Switch Load Balancing

Posted 2008. 9. 29. 07:12

출처 : Tong - 날으는오리님의 개발자통통



스위치 로드 밸런싱

이번에는 스위치간의 로드 밸런싱에 대해서 알아보겠습니다. (어쩌다 보니 강좌에
로드 밸런싱 이야기가 많이 나오네요. ^^  스위치 로드 밸런싱 문제는 최근 질문을
많이 받아서 한 번 정리합니다.)

스위치간의 로드 밸런싱은 STP 프로토콜의 특성을 이용해야 합니다.
STP가 타이를 깰 때 (tie breaking) 차례로 비교하는 값이 다음처럼
4가지가 있습니다.

1) 루트 스위치 ID
2) 경로값 (Path Cost)
3) 브리지 ID
4) 포트값 (Port Cost)

 

이중에서 현재의 스위치에서 조정 가능한 값은 경로값이며,
나머지는 모두 상대측 스위치에서 조정해 주어야 합니다.

 

스위치 네트워크의 토폴로지에 따라 위의 값 중에서 적당한 것을 이용하여
로드 밸런싱시키면 됩니다. 실제 각 경우별로 로드 밸런싱시켜보겠습니다.

1. 루트 스위치 ID를 이용하여 로드 밸런싱시키는 경우

이 방식은 주로 다음처럼 분배계층의 스위치가 레이어 3 기능이 있는
지역 VLAN 환경에서 많이 사용합니다.

>
다음처럼 스위치 S1을 VLAN 10의 루트 스위치로 설정하고 S2를
VLAN 20의 루트 스위치로 설정해 주면 됩니다.

S1(config)#spanning-tree vlan 10 priority 0

S2(config)#spanning-tree vlan 20 priority 0


그러면, 다음 그림처럼 스위치 S3의 F0/23을 통해서 VLAN 10 트래픽이 전송되고,
F0/24를 통해서 VLAN 20의 트래픽이 전송되므로 로드밸런싱이 일어납니다.
 

>

만약 스위치 S3의 링크중 하나가 다운되면 다음 그림처럼 나머지 링크를 통하여
모든 통신이 이루어지므로 백업 기능도 제공합니다.

>


2. 브리지 ID 조정을 이용한 로드 밸런싱

이번에는 다음처럼 분배계층의 스위치가 레이어 2이어서 하나의 VLAN이
전체 스위치 네트워크에 걸쳐있는 엔드 투 엔드 (end-to-end) VLAN이 설정되어
있는 경우를 생각해 봅시다.

>

스위치 S1과 S2에서 별도의 조정을 하지 않고, S1의 MAC 주소가 낮다면
앞의 그림처럼 VLAN 10, 20 모두 스위치 S1을 통하여 프레임이 전송됩니다.
여기서 로드 밸런싱을 시키려면 다음처럼 VLAN 20에 대해서는 스위치 S3과
S2를 연결하는 포트가 차단상태에 있는 NDP (Non-Designated Port,
또는 대체 포트)가 아니라 전송상태인 루트 포트 (RP)로 변경되어야 합니다.
이렇게 하기위해서는 스위치 S2의 우선순위값을 루트 스위치인 S4보다는
크지만 S1보다는 낮게 설정해주면 됩니다.

S4(config)#spanning-tree vlan 20 priority 0

S2(config)#spanning-tree vlan 20 priority 4096

그러면, 스위치 S3에서 루트 스위치로 전송되는 트래픽중 VLAN 20에 속하는 것은
스위치 S2를 통하여 전송되고, VLAN 10에 속하는 것은 스위치 S1을 통하므로
로드 밸런싱이 일어납니다.

3. 경로값 조정을 이용한 로드 밸런싱

다음처럼 두개의 스위치가 복수개의 링크로 연결된 경우에는 앞서 설명한
루트 스위치 ID나 브리지 ID 조정으로는 로드 밸런싱시킬 수가 없습니다.
이 때에는 포트의 경로값이나 포트 ID를 조정하면 됩니다.
물론, PAgP나 LACP를 이용하여 이더채널을 구성하는 것이 가장 이상적이지만
이런 프로토콜을 지원하지 못하는 스위치를 사용하는 경우에는
로드 밸런싱을 시키면 좀 불만스럽기는 하지만 그래도 약간은 위안이 됩니다.

아무런 설정을 하지 않으면 다음처럼 스위치 S2의 F0/24 포트가
모든 VLAN에 대해서 차단상태에 놓이게 되에 모든 트래픽이 F0/23 포트를
통하게 됩니다.

>

경로값을 조정하여 VLAN 20에 대해서 스위치 S2의 F0/24 포트가 루트 포트가 되어
전송상태로 변경시키면 됩니다. 이렇게 하기 위해서는 스위치 S2의 F0/23 포트에서
VLAN 20에 대한 경로값을 F0/24보다 높게 설정하거나, F0/24 포트에서 VLAN 20에
대한 경로값을 F0/23보다 낮게 설정하면 됩니다.

다음중 아무 방법이나 사용하면 됩니다.

S2(config)#int f0/23

S2(config-if)#spanning-tree vlan 20 cost 100

또는

S2(config)#int f0/24

S2(config-if)#spanning-tree vlan 20 cost 1

스위치 S2에서 결과를 확인해 보면 VLAN 10에 대해서는 F0/23이 전송상태가 됩니다.

S2#sh spann vlan 10


VLAN0010 

  Spanning tree enabled protocol ieee 

  Root ID    Priority    10 

             Address     000d.6507.3500 

             Cost        19 

             Port        23 (FastEthernet0/23) 

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec 


  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10) 

             Address     000d.edd4.2000 

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec 

             Aging Time 300 


Interface        Role Sts Cost      Prio.Nbr Type 

-------       -------- -------  -------------------

Fa0/23         Root FWD 19        128.23   P2p

Fa0/24          Altn BLK  19         128.24   P2p


또, VLAN 20에 대해서는 F0/24가 전송상태가 되어 로드 밸런싱이 이루어집니다.

S2#sh spann vlan 20


VLAN0020 

  Spanning tree enabled protocol ieee 

  Root ID    Priority    20 

             Address     000d.6507.3500 

             Cost        1 

             Port        24 (FastEthernet0/24) 

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec 


  Bridge ID  Priority    4116   (priority 4096 sys-id-ext 20) 

             Address     000d.edd4.2000 

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec 

             Aging Time 300 


Interface        Role Sts Cost      Prio.Nbr Type 

---------      --- ---------    --------------------------------

Fa0/23          Altn BLK 19        128.23   P2p

Fa0/24         Root FWD 1        128.24   P2p

>

 

4. 포트 ID 조정을 이용한 로드 밸런싱

마지막으로 포트 ID 조정을 이용한 로드 밸런싱에 대해서 알아보겠습니다.
바로 앞에서 사용한 동일한 네트워크에서 포트 ID를 조정하여도
로드 밸런싱을 구현할 수 있습니다.
그러나, 설정하는 스위치가 S1인 점이 다릅니다.

다음과 같이 S1의 F0/23에서 VLAN 20에 대한 포트 우선순위 값을 크게 하거나,

F0/24에서 VLAN 20에 대한 포트 우선순위 값을 낮게 하면 됩니다.

S1(config)#int f0/23

S1(config-if)#spanning-tree vlan 20 port-priority 240

또는

S1(config)#int f0/24

S1(config-if)#spanning-tree vlan 20 port-priority 16


그러나, 가능하다면 포트 우선순위 조정보다는 경로값을 조정하는 것이
더 편리하고 직관적입니다.

 


'Network > Cisco' 카테고리의 다른 글

Cisco TFTP 다운  (0) 2008.09.29
Switch Load Balancing  (0) 2008.09.29
Cisco 3750 기본 셋팅  (0) 2008.09.22
라우터 관리를 위한 명령어  (0) 2008.09.22
Write your message and submit

Cisco 3750 기본 셋팅

Posted 2008. 9. 22. 23:30

 

Cisco 3750

 

시스코 장비의 초기 패스워드는 전부 cisco 로 되어있습니다.

 

Privileged Mode(특권[관리자] 모드)

 

> enable

        Enter password : cisco

        #   <- 특권모드입니다.  셋팅에 관련된건 모두 특권모드에서 해야만 합니다.

 

 

콘솔로 들어가실려면 윈도우에서 지원하는 하이퍼터미널을 실행하셔야 합니다.

 

새연결(이름 아무꺼나 하셔도 됩니다)

연결대상에서  연결에 사용할 모뎀을 고르셔야 하는데 COM1(평균적으로 COM1을 많이 쓰입니다.)로 하시면 됩니다.

  

 

 

COM1 등록정보에서는

비트/ : 9600

데이터비트 8

패리티 없음

정비비트 1

흐름제어 없음을 하시면 됩니다.

 

 


 

그리고 확인을 누시면 Cisco3750으로 접속이 되실껍니다.

 

만약 접속이 되지 않는다면 통신포트를 바꾸어 주셔야 합니다.

 


 

1. 3750에서 VLAN을 나누는 방법입니다.

*vlan 2 설정*

SWITCH>enable

SWITCH#conf  termital

SWITCH(config)#vlan 2

SWITCH(config-vlan)#exit

SWITCH(config)#no vlan 2  <----- 지울때


 

2. 3750 장비에 ip를 설정할 수 있는데 ip를 설정하는 방법입니다.

설정된 VLAN을 가지고

SWITCH>enable

SWITCH#conf  termital

SWITCH(config)#interface vlan 2

SWITCH(config-if)#ip address 192.168.0.12 255.255.255.0

SWITCH(config-if)#no shutdown

SWITCH(config)#no interface vlan 2<----- 지울때

switch(config-vlan)#exit

switch(config)#ip default-gateway 10.10.10.1

 


 

3. 그리고 telnet 을 하려고 하는데 텔넷 설정하는 방법.

SWITCH(config)#line vty 0 4

SWITCH(config-line)#login

SWITCH(config-line)#password cisco


 


 

4. 그리고 생성된 vlan에 포트 할당 하는 방법

1번 포트를 vlan 2로 할당

SWITCH(config)#interface f0/1

SWITCH(config)#switchport access vlan 2

한꺼번에 할당하기(1번에서 5)

SWITCH(config)#interface range f0/1 - 5

SWITCH(config-if)#switchport access vlan 2


 


 

추가적으로 1~8은 디폴트
9~15
VLAN1, 16~24 VLAN2
이렇게 구성하려고 합니다.

SWITCH(config)#inter rang f0/9 - 15

SWITCH(config-if)#sw ac vlan 1

SWITCH(config)#inter rang f16~24

SWITCH(config-if)#sw ac vlan 2


 

참고로 시스코는 default vlan VLAN 1입니다.

그리고 시스코 스위치에 최초로 설정되어 있는 것은 VLAN 1이고

만일 포트에 다른 vlan을 할당하기 위해서는 먼저 vlan을 만들어야 합니다.


 

위처럼 설정하면 9-15번은 사실 설정을 하지 않아도 vlan 1번으로 할당 되어 있습니다.


 

확인 하는 방법은 SWITCH#show vlan  하시면 됩니다.

'Network > Cisco' 카테고리의 다른 글

Cisco TFTP 다운  (0) 2008.09.29
Switch Load Balancing  (0) 2008.09.29
Cisco 3750 기본 셋팅  (0) 2008.09.22
라우터 관리를 위한 명령어  (0) 2008.09.22
Write your message and submit

라우터 관리를 위한 명령어

Posted 2008. 9. 22. 22:42

>>>>  라우터 관리를 위한 명령들.... <<<<

>>> TFTP Server 설정...

 

>>> running-config 를 TFTP 에 Backup 하기

R1#copy running-config tftp
Address or name of remote host []? 192.168.2.2
Destination filename [r1-confg]? R1-Config
!!
1089 bytes copied in 5.516 secs (217 bytes/sec)
R1#

 

>>> TFTP에서 Running-config를 복구할 때는 먼저 Ethernet Interface에 IP 설정을 해서
      TFTP서버와 통신이 가능한 상태에서 진행한다...
R1#copy tftp running-config
Address or name of remote host []? 192.168.2.2
Source filename []? R1-Config
Destination filename [running-config]?
Accessing tftp://192.168.2.2/R1-Config...
Loading R1-Config from 192.168.2.2 (via Ethernet0): !
[OK - 1089/2048 bytes]

1089 bytes copied in 5.76 secs (217 bytes/sec)
R1#

 

>>> IOS Backup 하기

1. flash에 IOS Name을 체크한다.
R1#sh flash

System flash directory:
File  Length   Name/status
  1   5721700  c2500-i-l.120-8b.bin 
[5721764 bytes used, 2666844 available, 8388608 total]
8192K bytes of processor board System flash (Read ONLY)

 

2. flash에서 TFTP로 copy 해서 IOS를 백업한다.
R1#copy flash tftp
Source filename []? c2500-i-l.120-8b.bin
Address or name of remote host []? 192.168.2.2
Destination filename [c2500-i-l.120-8b.bin]?
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
5721700 bytes copied in 70.232 secs (81738 bytes/sec)
R1#


>>>  C2500 시리즈 IOS 업그래이드 하기

1. config-register값을 0x1 로 변경한다.
 Router(config)#config-register 0x1
 Router(config)#exit
 Router#reload

 

2. 먼저 enable 한후 설정 상태를 확인한다. TFTP서버와 통신이 되는지 검사...
R1(boot)>en
Password:
R1(boot)#sh ip int bri
Interface        IP-Address      OK?  Method    Status                 Protocol
Ethernet0        192.168.2.1    YES  NVRAM     up                     up     
Loopback0      192.168.1.1    YES  NVRAM     up                     up     
Serial0            192.168.3.2    YES  NVRAM     up                     up     
Serial1            unassigned     YES  not set     administratively down  down   
R1(boot)#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/203/1000 ms


R1(boot)#copy tftp flash

System flash directory:
File  Length   Name/status
  1   5721700  c2500-i-l.120-8b.bin 
[5721764 bytes used, 2666844 available, 8388608 total]
Address or name of remote host [255.255.255.255]? 192.168.2.2
Source file name? c2500-i-l.120-8b.bin
Destination file name [c2500-i-l.120-8b.bin]?
Accessing file 'c2500-i-l.120-8b.bin' on 192.168.2.2...
Loading c2500-i-l.120-8b.bin from 192.168.2.2 (via Ethernet0): ! [OK]

Erase flash device before writing? [confirm]
Flash contains files. Are you sure you want to erase? [confirm]

Copy 'c2500-i-l.120-8b.bin' from server
  as 'c2500-i-l.120-8b.bin' into Flash WITH erase? [yes/no]yes
Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ...erased
Loading c2500-i-l.120-8b.bin from 192.168.2.2 (via Ethernet0): !!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 5721700/8388608 bytes]

Verifying checksum...  OK (0x788F)
Flash copy took 0:02:50 [hh:mm:ss]
R1(boot)#

 

>>>  Cisco IOS 복원하기 (1600, 1700 , 2600 시리즈등...)
! TFTP 서버를 사용하는 경우
Example
     rommon 1 > IP_ADDRESS=171.68.171.0
     rommon 2 > IP_SUBNET_MASK=255.255.254.0
     rommon 3 > DEFAULT_GATEWAY=171.68.170.3
     rommon 4 > TFTP_SERVER=171.69.1.129
     rommon 5 > TFTP_FILE=c2600-is-mz.113-2.0.3.Q
     rommon 6 > tftpdnld

               IP_ADDRESS: 171.68.171.0
           IP_SUBNET_MASK: 255.255.254.0
          DEFAULT_GATEWAY: 171.68.170.3
              TFTP_SERVER: 171.69.1.129
                TFTP_FILE: c2600-is-mz.113-2.0.3.Q

     Invoke this command for disaster recovery only.
     WARNING: all existing data in all partitions on flash will be lost!
     Do you wish to continue? y/n:  [n]:  y

     Receiving c2600-is-mz.113-2.0.3.Q from 171.69.1.129 !!!!!.!!!!!!!!!!!!!!!!!!!.!!
     File reception completed.
     Copying file c2600-is-mz.113-2.0.3.Q to flash.
     Erasing flash at 0x607c0000
     program flash Location 0x60440000
     rommon 7 >reset

 

! Console 포트를 사용하는 경우
1. 먼저 라우터에 Xmodem 포트 설정을 한다.
rommon 1 > confreg
do you wish to change the configuration? y/n [n]:  y
enable  "diagnostic mode"? y/n  [n]:
enable  "use net in IP bcast address"? y/n  [n]:
disable "load rom after netboot fails"? y/n  [n]:

enable  "use all zero broadcast"? y/n  [n]:
enable  "break/abort has effect"? y/n  [n]:
enable  "ignore system config info"? y/n  [n]:
change console baud rate? y/n  [n]:  y
enter rate: 0 = 9600,  1 = 4800,  2 = 1200,  3 = 2400
            4 = 19200, 5 = 38400, 6 = 57600, 7 = 115200  [7]:  7
change the boot characteristics? y/n  [n]:  y
enter to boot:
 0 = ROM Monitor
 1 = the boot helper image
 2-15 = boot system
    [0]:  0

    Configuration Summary

enabled are:
load rom after netboot fails
console baud: 115200
boot: the ROM Monitor
do you wish to change the configuration? y/n  [n]: n
You must reset or power cycle for new config to take effect

 

2. Xmodem을 초기화 한다.
rommon 2 > xmodem -c c2600-is-mz.122-17.bin
Do not start the sending program yet...
         File size           Checksum   File name
 

3. 명령어를 입력한 다음

Terminal Client 프로그램에서 파일을 전송한다.

 

 

>>> 암호 복구 하기

1. 라우터에 콘솔 연결을 먼저 한다.
2. 라우터에 전원을 켜고 60초 이내에 [Ctrl + Break] or [Ctrl + B]를 누르면 다음 모드로 이동한다.
********************************************************************************************

<<<<< 2500 Serise >>>>>>
Abort at 0x10E5C1E (PC)
>

 

3. Register값을 0x2142로 변경한 후 재시작한다..
    (이 값은 NVRAM을 로드하지 않고 라우터 부팅을 한다.)
>o/r 0x2142
> i

 

<<<<< 16xx, 17xx, 26xx Serise 등 >>>>>>
rommon1>

 

3. Register 값을 0x2142로 변경후 재시작한다.
rommon1>confreg 0x2142
rommon2>reset
********************************************************************************************

 

4. NVRAM을 Pass하고 부팅하기 때문에 Setup Mode로 시작한다. Ctrl + C 로 Setup Mode를
    취소하고 라우터에 CLI Mode로 접근한다...

         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:


Press RETURN to get started!
<생략>
Router>

 

5. 라우터에 Privileged Mode로 이동 후 startup-config 를 running-config로 load 한다.

Router>en
Router#copy startup-config running-config
Destination filename [running-config]?
1089 bytes copied in 4.952 secs (272 bytes/sec)
R1#

 

6. 라우터에 기존에 설정되어 있던 Setting 정보가 복구되면 각 인터페이스 정보를 확인한다.
    startup-config에서 running-config를 강제 복구시 인터페이스가 활성화 되지 않는다.
    직접 각 인터페이스로 이동후 활성화를 한다....no shutdown를 입력해준다...
R1#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0             192.168.2.1     YES TFTP   administratively down down   
Loopback0           192.168.1.1     YES TFTP   up                    up     
Serial0                 192.168.3.2     YES TFTP   administratively down down   
Serial1                 unassigned      YES unset  administratively down down   
R1#conf t
R1(config)#int e0
R1(config-if)#no shutdown
R1(config-if)#int s0
R1(config-if)#no shutdown


7. 잃어버린 암호를 다시 설정한다.  (설정하고자 하는 암호를 입력한다.)
Router(config)#enable secret cisco

 

8. Register값을 원래대로 변경한다.  0x2102가 대부분 기본 값이다....
    이 정보는 각 라우터에서 먼저 show version으로 체크한 후에 기록해 놓는 것이 바람직하다..

Router(config)#config-register 0x2102

 

9. 이제 수정된 정보를 저장하고 다시 시작하면 완료된다.

Router#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]

R1#reload
Proceed with reload? [confirm]

 

완료>>>>>

'Network > Cisco' 카테고리의 다른 글

Cisco TFTP 다운  (0) 2008.09.29
Switch Load Balancing  (0) 2008.09.29
Cisco 3750 기본 셋팅  (0) 2008.09.22
라우터 관리를 위한 명령어  (0) 2008.09.22
Write your message and submit